What is EIGRP and why to use it?

Enhanced Interior Gateway Routing Protocol (EIGRP) is an advanced distance-vector routing protocol that is used to share routes with other routers within the same autonomous system (AS number). Unlike other routing protocols EIGRP was designed by Cisco Systems as a proprietary protocol, available only on Cisco routers. Furthermore EIGRP only sends incremental updates, reducing the workload on the router and the amount of data that needs to be transmitted.

In the network below there are a total of three routers and three end-user computers. In real world deployments a network could have dozens or hundreds of routers or devices depending on the scale of the network. Regardless of the network complexity dynamic routing serves the same role in that its purpose is to share routes with other routers so devices know how to transverse networks and remote devices can return traffic back to the requester. Hence, the creation of dynamic routing.

Steps to configure EIGRP

Step 1: Configure all applicable router interfaces.

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 10.1.0.1 255.255.255.0
!
R1(config)#interface FastEthernet1/0
R1(config-if)#ip address 10.253.0.1 255.255.255.252
!
R1(config)#interface FastEthernet1/1
R1(config-if)#ip address 10.251.0.1 255.255.255.252

Step 2: Enable a EIGRP routing process with a common AS number and enable EIGRP routing on all applicable IP networks.

R1(config)#router eigrp 101
R1(config-router)#network 10.1.0.0 0.0.0.255
R1(config-router)#network 10.251.0.0 0.0.0.3
R1(config-router)#network 10.253.0.0 0.0.0.3

In addition to the above, I recommend performing a few additional configurations for security purposes. This prevents the possibility of rogue routers from forming an adjacency and protect the routing table from willful or accidental corruption.

Step 3: Log neighbor up/down and reset reasons.

R1(config)#router eigrp 101
R1(config-router)#eigrp log-neighbor-changes

Step 4: Suppress routing updates out of interfaces not used to form an adjacency.

R1(config)#router eigrp 101
R1(config-router)#passive-interface FastEthernet0/0

Step 5: Configure static EIGRP neighbors.

R1(config-router)#router eigrp 101
R1(config-router)#neighbor 10.253.0.2 FastEthernet1/0
R1(config-router)#neighbor 10.251.0.2 FastEthernet1/1

Step 6: Configure EIGRP message authentication and enable on all interfaces used to form an adjacency.

R1(config)#key chain EIGRP-Keychain1
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string eigrp-password-here
!
R1(config)#interface FastEthernet1/0
R1(config-if)#ip authentication mode eigrp 101 md5
R1(config-if)#ip authentication key-chain eigrp 101 EIGRP-Keychain1

Caution: When peer authentication is added to the interface of a router, that router stops receiving routing messages from its peers until they are also configured for authentication. This does interrupt routing communications on your network.

Step 7: Configure password encryption on your routers so the passwords are not shown in the configuration in clear text.

R1(config)#service password-encryption

Step 8: Repeat the same steps on all remaining routers with the applicable interface and routing configurations.

Verify the configuration

Now that the configuration is finished lets verify our neighbors and routes. Using the show ip eigrp neighbors and show ip route commands you can verify the remote routes to which your router has formed and adjacency and verify the expected routes are being advertised. Use the ping command to verify connectivity.


Leave a Reply

Your email address will not be published. Required fields are marked *

Related Posts

Cisco Networking

BGP Load Sharing

What is load sharing and why to use it?Load balancing with BGP is not possible in a multihomed environment with two ISPs. BGP selects only the single best path to a destination among the BGP Read more…

Cisco Firewall

Configuring Dynamic Multipoint VPN and Zone Based Firewall

What is a Dynamic Multipoint VPN and why to use it?DMVPN provides the capability for creating a dynamic-mesh VPN network without having to pre-configure (static) all possible tunnel end-point peers, including IPsec (Internet Protocol Security) Read more…

Cisco Networking

Configuring Layer 2 MPLS VPN

What is a Layer 2 MPLS VPN and why to use it?Layer 2 VPNs are a type of Virtual Private Network (VPN) that uses MPLS labels to transport data. The communication occurs between routers that Read more…